Main Menu

The Main Menu allows you to perform common tasks, such as creating, opening, building and saving themes, customizing Theme Editor settings, etc.

File

UI_FileMenu

The File menu contains the following items.

  • New - invokes the New Theme dialog that allows you to create a new theme by cloning a predefined one. To learn more, see Creating and Opening Themes.
  • Open - opens a theme for editing. To learn more, see Creating and Opening Themes.
  • Upgrade Theme - upgrades the current theme to keep it compatible with the latest DXperience version. To learn more, see Theme Upgrade.
  • Save All - saves all modified files.
  • Close - closes the currently open theme.
  • Create Color Scheme - creates a color scheme file with default colors for the currently open theme. To learn more, see Color Schemes.
  • Open Color Scheme - opens a color scheme file.
  • Revert to Backup - rolls back the color scheme to a backup version.
  • Recent - a list of recently opened files (themes and color schemes). Select a file path from that list to reopen that file.
  • Settings - invokes the Settings dialog. For details, see Theme Editor Settings.
  • Exit - closes the Theme Editor.

View

UI_ViewMenu

The View menu contains the following items.

  • Preview - opens a specially designed complex layout painted with the currently edited theme. Use it to preview the theme applied to multiple controls. To learn more, see Editing Themes.
  • Reset Window Layout - resets the position and size of Theme Editor panels to default values.

Build

UI_BuildMenu

The Build menu contains the following items.

  • Build Theme - builds the current theme.
  • Clean Solution - removes all temporary files from the solution directory.

Look and Feel

UI_LookAndFeelMenu

The Look and Feel menu allows you to select a theme that should be used to paint the Theme Editor.

Help

UI_HelpMenu

The Help menu contains the following items.

  • Help - opens the Theme Editor documentation.
  • About - invokes the About window.