Skip to main content

Prerequisites

  • 3 minutes to read

This document contains information about system requirements to install and use DevExpress WinForms Controls.

.NET Framework

The table below highlights supported .NET Framework versions.

DevExpress Version .NET 2.0 .NET 3.5 .NET 4.0 .NET 4.5 .NET 4.5.2 .NET 4.6 .NET 4.7 .NET 4.8
v21.2-v22.1 (current) no no no no yes yes yes yes
v18.2-v21.1 no no no no yes yes yes yes
Other Versions
DevExpress Version .NET 2.0 .NET 3.5 .NET 4.0 .NET 4.5 .NET 4.5.2 .NET 4.6 .NET 4.7 .NET 4.8
v16.2-v18.1 no no yes yes yes yes yes no
v14.2-v16.1 no no yes yes yes yes no no
v13.1-v14.1 no no yes yes yes no no no
v12.1-v12.2 no yes yes yes yes no no no
v11.2 no yes yes no no no no no
v10.1-v11.1 yes yes yes no no no no no
v9.3 yes yes no no no no no no

Support for the .NET Client Profile has been discontinued by Microsoft with the release of .NET Framework 4.5. DevExpress controls v14.2 and higher do not support the .NET Client Profile.

.NET/.NET Core

The table below shows the versions of DevExpress WinForms Controls that support .NET.

DevExpress Version .NET Core 3.0 .NET Core 3.1 (LTS) .NET 5.0 .NET 6
v21.2-v22.1 (current) yes yes yes yes
v20.1-v21.1 yes yes yes no
Other Versions
DevExpress Version .NET Core 3.0 .NET Core 3.1 (LTS) .NET 5.0 .NET 6
v19.2.5+ yes yes no no
v19.1-v19.2.4 yes no no no

Prerequisites to build .NET applications:

See the following topic for more information: .NET/.NET Core Support.

IDE

The table below highlights Visual Studio versions supported by DevExpress WinForms Controls.

DevExpress Version Visual Studio 2005 Visual Studio 2008 Visual Studio 2010 Visual Studio 2012 Visual Studio 2013 Visual Studio 2015 Visual Studio 2017 Visual Studio 2019 Visual Studio 2022
v21.2 - v22.1 (current) no no no yes yes yes yes yes yes
v18.2 - v21.1 no no no yes yes yes yes yes[1] no
Other Versions
DevExpress Version Visual Studio 2005 Visual Studio 2008 Visual Studio 2010 Visual Studio 2012 Visual Studio 2013 Visual Studio 2015 Visual Studio 2017 Visual Studio 2019 Visual Studio 2022
v18.1 no no yes yes yes yes yes yes[2] no
v16.1.11-v17.2 no no yes yes yes yes yes no no
v14.2-v16.1.10 no no yes yes yes yes no no no
v12.2.15-v14.1 no no yes yes yes no no no no
v12.1-v12.2.14 no yes yes yes no no no no no
v11.2 no yes yes no no no no no no
v10.1-v11.1 yes yes yes no no no no no no
v9.3 yes yes no no no no no no no

In v18.2 and higher, DevExpress source code targets C# 6.0. You can still use our pre-compiled assemblies in Visual Studio 2012 and 2013. However, it is not possible to recompile DevExpress source code in these Visual Studio versions.

For both .NET and .NET Framework application development you need to install the .Net Desktop Development workload in Visual Studio. See this article for more information: Modify Visual Studio workloads, components, and language packs.

Visual Studio Express editions may not support all design-time features of DevExpress WinForms controls.

If you require a previous version of a DevExpress product, log in to the Download Manager page on the DevExpress website.

Footnotes
  1. Starting with v18.2.7.

  2. Starting with v18.1.11.