System Requirements

The CodeRush extension utilizes the "Roslyn" engine, which is natively supported by the Visual Studio 2015 IDE. This extension supports the following editions:

  • Visual Studio 2015 (Community, Professional and Enterprise editions)
  • Visual Studio 2017 (Community, Professional and Enterprise editions)
  • Visual Studio 2019 (Community, Professional and Enterprise editions)
NOTE

CodeRush does not support the Express edition, because third-party extensions do not work with any Express versions.

If you use an older Visual Studio version, consider the CodeRush Classic extension.