All docs
V20.2
20.2
20.1
The page you are viewing does not exist in version 20.1. This link will take you to the root page.
19.2
The page you are viewing does not exist in version 19.2. This link will take you to the root page.
19.1
The page you are viewing does not exist in version 19.1. This link will take you to the root page.
18.2
The page you are viewing does not exist in version 18.2. This link will take you to the root page.
18.1
The page you are viewing does not exist in version 18.1. This link will take you to the root page.
17.2
The page you are viewing does not exist in version 17.2. This link will take you to the root page.

Required Client Libraries

  • 2 minutes to read

The Web Dashboard uses the following client libraries:

Required

Optional

  • globalize 1.0+

    You can use Globalize as Intl alternative. The Web Dashboard uses the core Globalize script and four Globalize modules (message, number, date, and currency), as well as certain cldrjs scripts.

        <script src="Scripts/cldrjs/cldr.js"></script>
        <script src="Scripts/cldrjs/cldr.event.js"></script>
        <script src="Scripts/globalize/cldr.supplemental.js"></script>
    
        <script src="Scripts/globalize/globalize.js"></script>
        <script src="Scripts/globalize/globalize.message.js"></script>
        <script src="Scripts/globalize/globalize.number.js"></script>
        <script src="Scripts/globalize/globalize.currency.js"></script>
        <script src="Scripts/globalize/globalize.date.js"></script>
    

    Read more about Globalize modules and requirements in the Globalize documentation.

    The basic cldr content is included in the library. However, for locales other than "en" (or currencies other than "USD"), cldr content should be loaded additionally (read more in the Globalize documentation).

The DashboardControl requires the devexpress-dashboard npm package, its dependencies, devexpress-dashboard-angular and devextreme-angular packages:

  • jquery
  • knockout
  • @types/jquery
  • @devexpress/analytics-core
  • devextreme
  • devexpress-dashboard-angular
  • devextreme-angular

Use npm install command to install packages.

See Also