Skip to main content

.NET/.NET Core Support

  • 2 minutes to read

Prerequisites

The table below shows the versions of DevExpress WPF Controls that support .NET/.NET Core.

DevExpress Version .NET Core 3.0 .NET Core 3.1 (LTS) .NET 5.0 .NET 6.0
v22.1(current) yes yes yes yes
v20.1-v21.2 yes yes yes no
v19.2.5+ yes yes no no
v19.1-v19.2.4 yes no no no

Prerequisites to build .NET Core applications:

Getting Started

The Getting Started topic explains how to start using DevExpress WPF UI controls in a .NET WPF application.

Migrate an Existing Application to .NET

The following topic describes how to migrate an existing WPF Application to .NET: Migrate WPF Applications to .NET.

Deployment

The following topic describes how to deploy your .NET WPF application: Deploy .NET Applications.

Limitations

The following features are not supported:

Create Custom Themes for .NET Applications with the Theme Designer

  1. Install DevExpress WPF Controls for the .NET Framework.
  2. Build and publish your custom theme that targets the .NET Framework in the Theme Designer.
  3. Reference the resulting assembly in .NET projects.

Theme projects contain XAML resources and no C# or VB code, and there are no conflicts between the .NET Framework and .NET.