System Requirements (CodeRush Classic)

This document describes the system requirements for installing and using CodeRush Classic on a development machine. If you are working with an older version of the IDE that is not supported by the current version of CodeRush Classic, please refer to the Visual Studio Support History topic to choose the most appropriate CodeRush Classic version.

You can use CodeRush Classic with any of the following IDEs:

  • Microsoft Visual Studio 2010;
  • Microsoft Visual Studio 2012;
  • Microsoft Visual Studio 2013;
  • Microsoft Visual Studio 2015.